Install it on Joomla 2.5

  • Published in FAQs
  • Updated 14 Mar, 2017

Since version 2.3, compatibility and support of Responsive Scroll Triggered Box for Joomla 2.5 has been dropped. However if you have an active subscription you can download and use older versions. View all releases or download the last Joomla 2.5 compatible version (2.2.1) from here.

Note

You will need to login to your account and have an active subscription. If you don't have a valid subscription click here

Get Engage Box for Joomla! for just 29€ Get it now!
Don't miss a thing!
Stay up-to-dated with my latest blog articles
Receive updates for my Joomla Extensions
No Spam! It's a promise.