Install it on Joomla older than 3.4

  • Published in FAQs
  • Updated 14 Mar, 2017

Since Engage Box v2.3 has came out the minimum required Joomla version was set to 3.4. This means that if your Joomla website is running on an older version than 3.4 you are not able to install it.

However, having access to the older releases you can download the last compatible version for Joomla 3.3, 3.2 or 3.1 which is v2.2.1.

Download v2.2.1
Get Engage Box for Joomla! for just 29€ Get it now!
Don't miss a thing!
Stay up-to-dated with my latest blog articles
Receive updates for my Joomla Extensions
No Spam! It's a promise.
BLACK FRIDAY SALE 30% off any Tassos.gr extension. Coupon code BLACKMONDAY17